vJASS & Zinc Documentation
For the latest documentation about how it works vJASS and Zinc language layers for Warcraft III, please follow these links:
Jasshelper documentation - Zinc documentation - WC3 Optimizer documentation

* Random Tools

A new TESH Syntax Highlighter for Warcraft 3

Views: 2075
Replies: 2
Posted by BlizzMod
March 28, 2017, 10:53:33 PM

UnrealLoader [Universal kLoader]

Views: 5186
Replies: 3
Posted by karaulov
February 12, 2017, 04:53:30 PM

vrJASS

Views: 4052
Replies: 2
Posted by Ruke
June 02, 2016, 11:00:57 PM

Jasshelper 2014-03-10

Views: 7479
Replies: 1
Posted by Glowackos
November 27, 2014, 09:39:52 AM

Warcraft 3 Art Tools 1.01

Views: 7718
Replies: 0
Posted by moyack
April 28, 2012, 07:55:04 AM

The Jass NewGen Pack (JNGP) 2.0

moyack · 237006

0 Members and 2 Guests are viewing this topic.

Rating

Average Score - 5 / 5

« Created: June 13, 2018, 01:02:00 PM by yxq1122 »
+ Show previous

The Jass NewGen Pack (JNGP) 2.0
Reply #25 on: July 24, 2013, 09:04:55 AM

The emulation also can be found in BlizzMod folder [if I was right, its name was Blizzard Modding/BlizzMod]
Edit the configuration.txt path to Warcraft 3 path then run the Multiplayer Emulation, it should solve it.
You can do this, but from time to time this path is changed by JNGP. I think I'd add an option to force a WC3 path installation and solve this issue in some installations.


The Jass NewGen Pack (JNGP) 2.0
Reply #26 on: July 26, 2013, 11:21:02 AM

NewGen WE.exe runs and instantly closes. what am i doing wrong?



The Jass NewGen Pack (JNGP) 2.0
Reply #27 on: July 26, 2013, 12:49:15 PM

NewGen WE.exe runs and instantly closes. what am i doing wrong?
Please try to load first we.bat, located in the same folder in JNGP.


The Jass NewGen Pack (JNGP) 2.0
Reply #28 on: July 26, 2013, 10:58:49 PM

Please try to load first we.bat, located in the same folder in JNGP.
i did... ;( I have both legit (c:\program files) and cracked (c:\games) warcraft installed. we.bat locates path of legit one. I  don't see any configuration files where I could change that or modify any other settings to try make it work. :s

OS - winXP sp3.



The Jass NewGen Pack (JNGP) 2.0
Reply #29 on: July 27, 2013, 01:46:27 AM

TQ downloading



The Jass NewGen Pack (JNGP) 2.0
Reply #30 on: July 27, 2013, 01:55:33 AM

JNGP Status
7/27/2013 1:55:23 PM
Code: [Select]
Operative System:
 - Windows Version: Windows XP
 - 32 or 64 Bits: 32 Bits

Video Card Information:
 - Device String:Mobile Intel(R) 4 Series Express Chipset Family
 - Device Name:\\.\DISPLAY1
 - Device Key:\REGISTRY\Machine\System\ControlSet001\Services\ialm\Device0
 - Device ID:PCI\VEN_8086&DEV_2A42&SUBSYS_02141025&REV_07

Warcraft III Current Settings:
 - WC3 Path:
 - War3.exe location: No file found!!! Please Check your WC3 installation...
 - JNGP WC3 Path: D:\Games\Warcraft III
                 (Warning: JNGP has not detected properly WC3 Path)

Jass NewGen Pack Information:
 - Version: 2.0.4
 - Blizzmod Folder: E:\Games\Warcraft III Part\Warcraft III\Tools\jassnewgenpack204\blizzmod
 - Multi Loader Status:
   > Executable: YES
   > Library DLL: YES
   > Config File: YES
   > Current Config Text: C:\Program Files\Warcraft III\war3.exe -window
 - Custom Menu Settings:
   > Config file: NO
   > LUA Menu: NO



The Jass NewGen Pack (JNGP) 2.0
Reply #31 on: July 27, 2013, 02:55:25 AM

@demented
Make sure you turn off your antivirus, especially Kaspersky when using NewGen.

@LembidiZ
The path is not configured correctly, what are you trying to do? Running Multiplayer Emulation

@Moyack
I want to inform you that I don't see the menus for adding tools, I presume I'm the only one who's blind.... Is the menu for adding external tools already implemented?
Also, keep up the good work  :D



The Jass NewGen Pack (JNGP) 2.0
Reply #32 on: July 27, 2013, 01:25:31 PM

JNGP Status
7/27/2013 1:55:23 PM
Code: Text
  1. Operative System:
  2.  - Windows Version: Windows XP
  3.  - 32 or 64 Bits: 32 Bits
  4.  
  5. Video Card Information:
  6.  - Device String:Mobile Intel(R) 4 Series Express Chipset Family
  7.  - Device Name:\\.\DISPLAY1
  8.  - Device Key:\REGISTRY\Machine\System\ControlSet001\Services\ialm\Device0
  9.  - Device ID:PCI\VEN_8086&DEV_2A42&SUBSYS_02141025&REV_07
  10.  
  11. Warcraft III Current Settings:
  12.  - WC3 Path:
  13.  - War3.exe location: No file found!!! Please Check your WC3 installation...
  14.  - JNGP WC3 Path: D:\Games\Warcraft III
  15.                  (Warning: JNGP has not detected properly WC3 Path)
  16.  
  17. Jass NewGen Pack Information:
  18.  - Version: 2.0.4
  19.  - Blizzmod Folder: E:\Games\Warcraft III Part\Warcraft III\Tools\jassnewgenpack204\blizzmod
  20.  - Multi Loader Status:
  21.    > Executable: YES
  22.    > Library DLL: YES
  23.    > Config File: YES
  24.    > Current Config Text: C:\Program Files\Warcraft III\war3.exe -window
  25.  - Custom Menu Settings:
  26.    > Config file: NO
  27.    > LUA Menu: NO
As I thought, your bad WC3 installation is the issue. I'll add a small improvement to JNGP so anybody can force a WC3 path installation.

@Moyack
I want to inform you that I don't see the menus for adding tools, I presume I'm the only one who's blind.... Is the menu for adding external tools already implemented?
Also, keep up the good work  :D
In the JNGP 2.0 Menu there's the option "Custom Menu Settings" or something like that, After multiplayer emulation.
« Last Edit: July 27, 2013, 03:19:32 PM by moyack »



The Jass NewGen Pack (JNGP) 2.0
Reply #33 on: July 28, 2013, 06:21:30 AM

thanks for the answer :D



The Jass NewGen Pack (JNGP) 2.0
Reply #34 on: August 30, 2013, 05:18:13 AM

I have problem with multiplayer emulation.
As I thought, your bad WC3 installation is the issue. I'll add a small improvement to JNGP so anybody can force a WC3 path installation.
In the JNGP 2.0 Menu there's the option "Custom Menu Settings" or something like that, After multiplayer emulation.
How can i do that?

The emulation also can be found in BlizzMod folder [if I was right, its name was Blizzard Modding/BlizzMod]
W3MultipleLoader? Can`t launch second application, error:"Wc3 is unable to initialize".
Edit the configuration.txt path to Warcraft 3 path then run the Multiplayer Emulation, it should solve it.
JNGP always change path from right to "\war3. exe - windowed" when i start multiplayer emulation

From JNGP settings:
- War3.exe location: No file found!!! Please Check your WC3 installation...
 - JNGP WC3 Path: C:\games\Warcraft III\
                 (Warning: JNGP has not detected properly WC3 Path)
« Last Edit: August 30, 2013, 05:55:32 AM by Figase »



The Jass NewGen Pack (JNGP) 2.0
Reply #35 on: August 30, 2013, 08:20:08 AM

I have problem with multiplayer emulation.How can i do that?
W3MultipleLoader? Can`t launch second application, error:"Wc3 is unable to initialize".JNGP always change path from right to "\war3. exe - windowed" when i start multiplayer emulation

From JNGP settings:
- War3.exe location: No file found!!! Please Check your WC3 installation...
 - JNGP WC3 Path: C:\games\Warcraft III\
                 (Warning: JNGP has not detected properly WC3 Path)

Hi Figase, and welcome to Blizzmod :)

Yes, I'm working in the definition of WC3 path so it can solve this bug, hopefully this Saturday I'll take the code and fix this. Please stay tunned!!! :D


The Jass NewGen Pack (JNGP) 2.0
Reply #36 on: August 31, 2013, 06:00:17 AM

I love you man, this tool is really well, excellent ? perfect ? Whatever...

Thanks in advanced !!!

Ps: Anyway, is there any way to convert this tool in other language ?



The Jass NewGen Pack (JNGP) 2.0
Reply #37 on: August 31, 2013, 06:26:30 AM

I love you man, this tool is really well, excellent ? perfect ? Whatever...

Thanks in advanced !!!

Ps: Anyway, is there any way to convert this tool in other language ?
Thanks for your support :)

I'm pretty sure this program is not perfect, but we'll try to achieve this goal :P

Why do you want to convert it into another language??


The Jass NewGen Pack (JNGP) 2.0
Reply #38 on: September 01, 2013, 01:47:19 PM

JNGP 2.0.5. is up to run!!!!

Changelog:
  • Improved the WC3 path detection, I hope with this the issues with misreadings paths gets solved.
  • Improved the map loading, now you can choose to set the original name and it will load the file path for later deletion or to whatever you like.
  • Removed unnecessary files (Thanks PurgeandFire :)


Please comment any bugs, motivate me... or whatever. Enjoy!!!


The Jass NewGen Pack (JNGP) 2.0
Reply #39 on: September 03, 2013, 05:33:35 AM

Still the "Unspecified Path" bug again ???



The Jass NewGen Pack (JNGP) 2.0
Reply #40 on: September 03, 2013, 08:16:17 AM

I can't download the attachment :( Seem server's quite busy...

Could you provide an external link to download like MediaFire or MEGA ?

-------------

P/S: Well, after use VPS to download, now I can download it :P But I can't use JNGP 2.0.5. It's always tell me that WC3 not found path, so I'm back to 2.0.4 and here is the my settings...

JNGP Status
3/9/2013 10:13:25 PM
Code: [Select]
Operative System:
 - Windows Version: Windows XP
 - 32 or 64 Bits: 32 Bits

Video Card Information:
 - Device String:Intel(R) 82865G Graphics Controller
 - Device Name:\\.\DISPLAY1
 - Device Key:\REGISTRY\Machine\System\ControlSet003\Services\ialm\Device0
 - Device ID:PCI\VEN_8086&DEV_2572&SUBSYS_017A1028&REV_02

Warcraft III Current Settings:
 - WC3 Path:
 - War3.exe location: No file found!!! Please Check your WC3 installation...
 - JNGP WC3 Path: D:\5-GAMES\Warcraft III
                 (Warning: JNGP has not detected properly WC3 Path)

Jass NewGen Pack Information:
 - Version: 2.0.4
 - Blizzmod Folder: D:\3-MMK DEV FOLDER\5-LCNG DESIGN PACK\blizzmod
 - Multi Loader Status:
   > Executable: YES
   > Library DLL: YES
   > Config File: YES
   > Current Config Text: C:\Program Files\Warcraft III\war3.exe -window
 - Custom Menu Settings:
   > Config file: YES
   > LUA Menu: YES
   > Current Config Text:

=== TEXT START ===
[CSTMENU]
ITEMS=3
MNU_NAME_0=VXMapOptimizer
MNU_PATH_0=D:\3-MMK DEV FOLDER\5-LCNG DESIGN PACK\xtools\WC3MapOptimizer\VXJWTSOPT.exe
MNU_NAME_1=SLKOptimizer
MNU_PATH_1=D:\3-MMK DEV FOLDER\5-LCNG DESIGN PACK\xtools\Wc3SLKOpt\Wc3SLKOpt.exe
MNU_NAME_2=BLP Laboratory
MNU_PATH_2=D:\3-MMK DEV FOLDER\5-LCNG DESIGN PACK\xtools\BLPLaboratory\blplab.exe

==== TEXT END ====

   > Current LUA Menu code:

=== TEXT START ===
--==============================
--|   Automated menu script    |
--|     made by JNGP 2.0       |
--|  For bug reporting visit:  |
--|  [url=http://www.blizzardmodding.info]www.blizzardmodding.info[/url]  |
--==============================
--   Last update:
--   3/9/2013 9:41:40 PM
--==============================

function MNUVXMapOptimizer()
  wehack.runprocess("blizzmod\\MTT.exe --command=0")
end


function MNUSLKOptimizer()
  wehack.runprocess("blizzmod\\MTT.exe --command=1")
end


function MNUBLPLaboratory()
  wehack.runprocess("blizzmod\\MTT.exe --command=2")
end

MNUVXMapOptimizerm = MenuEntry:New(jngpm,"VXMapOptimizer...",MNUVXMapOptimizer)
MNUSLKOptimizerm = MenuEntry:New(jngpm,"SLKOptimizer...",MNUSLKOptimizer)
MNUBLPLaboratorym = MenuEntry:New(jngpm,"BLP Laboratory...",MNUBLPLaboratory)

==== TEXT END ====
« Last Edit: September 03, 2013, 10:16:23 AM by Destro »



The Jass NewGen Pack (JNGP) 2.0
Reply #41 on: September 03, 2013, 11:15:59 AM

Still the "Unspecified Path" bug again ???
I can't download the attachment :( Seem server's quite busy...

Could you provide an external link to download like MediaFire or MEGA ?

-------------

P/S: Well, after use VPS to download, now I can download it :P But I can't use JNGP 2.0.5. It's always tell me that WC3 not found path, so I'm back to 2.0.4 and here is the my settings...

JNGP Status
3/9/2013 10:13:25 PM
Code: [Select]
Operative System:
 - Windows Version: Windows XP
 - 32 or 64 Bits: 32 Bits

Video Card Information:
 - Device String:Intel(R) 82865G Graphics Controller
 - Device Name:\\.\DISPLAY1
 - Device Key:\REGISTRY\Machine\System\ControlSet003\Services\ialm\Device0
 - Device ID:PCI\VEN_8086&DEV_2572&SUBSYS_017A1028&REV_02

Warcraft III Current Settings:
 - WC3 Path:
 - War3.exe location: No file found!!! Please Check your WC3 installation...
 - JNGP WC3 Path: D:\5-GAMES\Warcraft III
                 (Warning: JNGP has not detected properly WC3 Path)

Jass NewGen Pack Information:
 - Version: 2.0.4
 - Blizzmod Folder: D:\3-MMK DEV FOLDER\5-LCNG DESIGN PACK\blizzmod
 - Multi Loader Status:
   > Executable: YES
   > Library DLL: YES
   > Config File: YES
   > Current Config Text: C:\Program Files\Warcraft III\war3.exe -window
 - Custom Menu Settings:
   > Config file: YES
   > LUA Menu: YES
   > Current Config Text:

=== TEXT START ===
[CSTMENU]
ITEMS=3
MNU_NAME_0=VXMapOptimizer
MNU_PATH_0=D:\3-MMK DEV FOLDER\5-LCNG DESIGN PACK\xtools\WC3MapOptimizer\VXJWTSOPT.exe
MNU_NAME_1=SLKOptimizer
MNU_PATH_1=D:\3-MMK DEV FOLDER\5-LCNG DESIGN PACK\xtools\Wc3SLKOpt\Wc3SLKOpt.exe
MNU_NAME_2=BLP Laboratory
MNU_PATH_2=D:\3-MMK DEV FOLDER\5-LCNG DESIGN PACK\xtools\BLPLaboratory\blplab.exe

==== TEXT END ====

   > Current LUA Menu code:

=== TEXT START ===
--==============================
--|   Automated menu script    |
--|     made by JNGP 2.0       |
--|  For bug reporting visit:  |
--|  [url=http://www.blizzardmodding.info]www.blizzardmodding.info[/url]  |
--==============================
--   Last update:
--   3/9/2013 9:41:40 PM
--==============================

function MNUVXMapOptimizer()
  wehack.runprocess("blizzmod\\MTT.exe --command=0")
end


function MNUSLKOptimizer()
  wehack.runprocess("blizzmod\\MTT.exe --command=1")
end


function MNUBLPLaboratory()
  wehack.runprocess("blizzmod\\MTT.exe --command=2")
end

MNUVXMapOptimizerm = MenuEntry:New(jngpm,"VXMapOptimizer...",MNUVXMapOptimizer)
MNUSLKOptimizerm = MenuEntry:New(jngpm,"SLKOptimizer...",MNUSLKOptimizer)
MNUBLPLaboratorym = MenuEntry:New(jngpm,"BLP Laboratory...",MNUBLPLaboratory)

==== TEXT END ====
Ok... then my tests doesn't cover properly all the situation... snif :'(

I'll work in a DEFINITELY WINDOWS PROOF way to solve this: via user defined way. Please stay tunned.


The Jass NewGen Pack (JNGP) 2.0
Reply #42 on: September 07, 2013, 10:00:37 PM

Idk why but each time i open the editor it tells me it doesn't detect war3



The Jass NewGen Pack (JNGP) 2.0
Reply #43 on: September 08, 2013, 01:21:10 AM

Idk why but each time i open the editor it tells me it doesn't detect war3

same with me.
Moyack is working on it.



The Jass NewGen Pack (JNGP) 2.0
Reply #44 on: September 09, 2013, 12:42:26 AM

Just to add some WIP...

The way to set manually the WC3 path :D



The Jass NewGen Pack (JNGP) 2.0
Reply #45 on: September 10, 2013, 02:25:42 AM

Nice! We're waiting for it  ;D ;D ;D ;D



The Jass NewGen Pack (JNGP) 2.0
Reply #46 on: September 12, 2013, 07:23:44 AM

About the path bug, JNGP finds the correct path (at least for me) but fails to see the executable. Perhaps the way you are trying to access it has problem with spaces/special characters?

Btw is there any update on the new TESH?
« Last Edit: September 12, 2013, 08:35:08 AM by psxlover »



The Jass NewGen Pack (JNGP) 2.0
Reply #47 on: September 12, 2013, 03:14:33 PM

About the path bug, JNGP finds the correct path (at least for me) but fails to see the executable. Perhaps the way you are trying to access it has problem with spaces/special characters?
Until my latest test, I haven't seen that could be the issue. Unless someone send me a debug information (menu JNGP 2.0 > JNGP Status) I could confirm that possibility.

Quote
Btw is there any update on the new TESH?
By the moment, no. I hope Looking_for_help finishes some uber nice improvements in the editor.


The Jass NewGen Pack (JNGP) 2.0
Reply #48 on: September 15, 2013, 03:30:56 AM

Hey, i just downloaded the lates verson ( 2.0.5 ) and as i started it, the errors messages comes...

"Wc3 Path can't be found by JNPG..."
« Last Edit: September 15, 2013, 04:10:50 AM by pred1980 »



The Jass NewGen Pack (JNGP) 2.0
Reply #49 on: September 15, 2013, 02:34:36 PM

Hey, i just downloaded the lates verson ( 2.0.5 ) and as i started it, the errors messages comes...

"Wc3 Path can't be found by JNPG..."
I hope this version fixes once for all this issue (that's really annoying me) :(

JNGP 2.0.6
  • Improved a lot the path detection. Plus it now comes with an interface to set manually you WC3 path.
  • Improved the Map loading a little bit. Now testing a map with spaces in the name will work. UI will show the name so you can set it up in the replay and it will open the location where's the file.
  • Improved the documentation of Campaign Compiler and fixed some documentation paths.


Enjoy!!!! and report any bug. Thanks!!
« Last Edit: September 15, 2013, 02:59:10 PM by moyack »



 

Chaos Realm - The world of Game modders and wc3 addicts     WC3JASS.com - The JASS Vault   Jetcraft - A Starcraft II mod